blob: d3984abe8b0ab900312d8c3dd023a05e71f86cd7 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "yaml-cpp parser and emitter library"
2DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec."
3HOMEPAGE = "https://github.com/jbeder/yaml-cpp"
4SECTION = "devel"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
7
8# yaml-cpp releases are stored as archive files in github.
9# download the exact revision of release
10SRC_URI = "git://github.com/jbeder/yaml-cpp.git;branch=master;protocol=https"
11SRCREV = "0579ae3d976091d7d664aa9d2527e0d0cff25763"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE = "-DYAML_CPP_BUILD_TESTS=OFF -DYAML_BUILD_SHARED_LIBS=ON -DYAML_CPP_BUILD_TOOLS=OFF"