blob: 34dd8c86862579e511c23ffa1a52762e0a587748 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Linux firmware validation framework"
2DESCRIPTION = "Cukinia is designed to help Linux-based embedded firmware \
3developers run simple system-level validation tests on their firmware."
4HOMEPAGE = "https://github.com/savoirfairelinux/cukinia"
5LICENSE = "GPLv3 & Apache-2.0"
6
7LIC_FILES_CHKSUM = "file://LICENSE.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
8 file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10SRC_URI = "git://github.com/savoirfairelinux/cukinia.git;protocol=https;branch=master"
11
12SRCREV = "ea934c5393ad99c37bec3c621a364122720cce02"
13
14S = "${WORKDIR}/git"
15
16do_install () {
17 install -d ${D}${sbindir}
18 install -m 0755 ${S}/cukinia ${D}${sbindir}
19}