blob: 65b54ed548dcc57618ab406f5874a44c0fa90cbd [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit."
2HOMEPAGE = "http://cxxtest.com/"
3SECTION = "devel"
4LICENSE = "LGPL-2.0"
Andrew Geissler595f6302022-01-24 19:11:47 +00005LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
Brad Bishop19323692019-04-05 15:28:33 -04006
Andrew Geissler595f6302022-01-24 19:11:47 +00007SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/${BP}.tar.gz"
Brad Bishop19323692019-04-05 15:28:33 -04008SRC_URI[md5sum] = "c3cc3355e2ac64e34c215f28e44cfcec"
9SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f4895cf7d8"
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011inherit setuptools3
Brad Bishop19323692019-04-05 15:28:33 -040012
Andrew Geissler595f6302022-01-24 19:11:47 +000013SETUPTOOLS_SETUP_PATH = "${S}/python"
Brad Bishop19323692019-04-05 15:28:33 -040014
Patrick Williams213cb262021-08-07 19:21:33 -050015do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040016 install -d ${D}${includedir}
Andrew Geissler595f6302022-01-24 19:11:47 +000017 cp -a ${S}/cxxtest/ ${D}${includedir}
18 # Fix the interpretter as otherwise this points to the build host python
Brad Bishop19323692019-04-05 15:28:33 -040019 sed '1c\
Andrew Geissler595f6302022-01-24 19:11:47 +000020#!/usr/bin/env python3' -i ${D}${bindir}/cxxtestgen
Brad Bishop19323692019-04-05 15:28:33 -040021}
22
23BBCLASSEXTEND = "native nativesdk"