blob: 1d8434e3ca43fbf20ce3145aac500b1f2effa181 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Async http client/server framework"
2DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
3HOMEPAGE = "https://github.com/aio-libs/aiohttp"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8074d6c6e217873b2a018a4522243ea3"
6
7SRC_URI[sha256sum] = "fc5471e1a54de15ef71c1bc6ebe80d4dc681ea600e68bfd1cbce40427f0b7578"
8
9PYPI_PACKAGE = "aiohttp"
10inherit setuptools3 pypi
11RDEPENDS:${PN} = "\
12 ${PYTHON_PN}-async-timeout \
13 ${PYTHON_PN}-attrs \
14 ${PYTHON_PN}-chardet \
15 ${PYTHON_PN}-html \
16 ${PYTHON_PN}-idna-ssl \
17 ${PYTHON_PN}-json \
18 ${PYTHON_PN}-misc \
19 ${PYTHON_PN}-multidict \
20 ${PYTHON_PN}-netserver \
21 ${PYTHON_PN}-typing-extensions \
22 ${PYTHON_PN}-yarl \
23 ${PYTHON_PN}-cchardet \
24 ${PYTHON_PN}-charset-normalizer \
25 ${PYTHON_PN}-aiosignal \
26"