blob: df50bc7a89bb46501dd68edb4cd5c4476e5a13dd [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRPTION = "ansi2html - Convert text with ANSI color codes to HTML or to LaTeX"
2HOMEPAGE = "https://github.com/ralphbean/ansi2html"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3000208d539ec061b899bce1d9ce9404"
4LICENSE = "GPLv3"
5
6PYPI_PACKAGE = "ansi2html"
7
8SRC_URI[sha256sum] = "69316be8c68ac91c5582d397c2890e69c993cc7cda52062ac7e45fcb660d8edc"
9
10inherit pypi setuptools3
11
12DEPENDS += " \
13 ${PYTHON_PN}-setuptools-scm-native \
14 ${PYTHON_PN}-toml-native \
15"
16
17RDEPENDS:${PN} = " \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-compression \
20"
21
22do_compile:prepend() {
23 echo "from setuptools import setup" > ${S}/setup.py
24 echo "setup()" >> ${S}/setup.py
25}