blob: 76f7a8e6522fd644d65f5081af0918ca85edf6a7 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8"
10
11SRC_URI[sha256sum] = "8458d7b1287c5fb128c90e23381cf99dcde74beaf6c7ff6384ce84d6fe090adb"
12
13inherit pypi setuptools3 ptest
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 ${PYTHON_PN}-pytest \
21 ${PYTHON_PN}-terminal \
22 ${PYTHON_PN}-unixadmin \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28 cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
29 cp -rf ${S}/docs ${D}${PTEST_PATH}/
30}
31
32UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
33
34CLEANBROKEN = "1"
35
36RDEPENDS:${PN} += "\
37 ${PYTHON_PN}-io \
38 ${PYTHON_PN}-threading \
39 "
40
41BBCLASSEXTEND = "native nativesdk"