blob: 4070fc01280047ed9609bfa566f937b08f311220 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
9SRC_URI[sha256sum] = "e1120c228ca2f553b470df4a5fa927ab66258467526069981b3eb0a91902687d"
10
11PYPI_PACKAGE = "Flask"
12
13inherit pypi setuptools3
14
15CLEANBROKEN = "1"
16
17RDEPENDS:${PN} = " \
18 ${PYTHON_PN}-werkzeug \
19 ${PYTHON_PN}-jinja2 \
20 ${PYTHON_PN}-itsdangerous \
21 ${PYTHON_PN}-click \
22 ${PYTHON_PN}-profile \
23"