blob: 330831a0b3d90ee7c79791544ab9f90091b7a08f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "generate GCC code coverage reports"
2HOMEPAGE = "https://gcovr.com"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=08208c66520e8d69d5367483186d94ed"
6
7SRC_URI = "git://github.com/gcovr/gcovr.git;branch=master;protocol=https"
8SRCREV = "2b50284e8a6792b4ddcba14e2050c5c05f15deb6"
9
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13
14RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments"
15
16BBCLASSEXTEND = "native nativesdk"