blob: fdc4ad9cc2b9cc1b45829830de945b2b9723a6ff [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
13
14SRC_URI[sha256sum] = "f16e4c63996ca8fe0af1eb9c4a07e5207874c4a69f890ccb824cd858521d981f"
15
16RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
17
18BBCLASSEXTEND = "native nativesdk"
19
20# Needs abseil-cpp which does not build for ppc64le/musl
21COMPATIBLE_HOST:libc-musl:powerpc64le = "null"
22