blob: 43f071281dc62858fad5a67c793262cbf441b14c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API."
2DESCRIPTION = "lxml is a Pythonic, mature binding for the libxml2 and \
3libxslt libraries. It provides safe and convenient access to these \
4libraries using the ElementTree API. It extends the ElementTree API \
5significantly to offer support for XPath, RelaxNG, XML Schema, XSLT, \
6C14N and much more."
7HOMEPAGE = "https://lxml.de/"
8SECTION = "devel/python"
9LICENSE = "BSD-3-Clause & GPLv2 & MIT & PSF"
10LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=e4c045ebad958ead4b48008f70838403 \
11 file://doc/licenses/elementtree.txt;md5=eb34d036a6e3d56314ee49a6852ac891 \
12 file://doc/licenses/BSD.txt;md5=700a1fc17f4797d4f2d34970c8ee694b \
13 file://doc/licenses/GPL.txt;md5=94d55d512a9ba36caa9b7df079bae19f \
14 file://src/lxml/isoschematron/resources/rng/iso-schematron.rng;beginline=2;endline=7;md5=fc85684a8dd5fa272c086bceb0d99e10 \
15 file://src/lxml/isoschematron/resources/xsl/iso-schematron-xslt1/iso_schematron_message.xsl;beginline=2;endline=24;md5=cc86b7b2bbc678e13f58ea403eb9929b \
16 file://src/lxml/isoschematron/resources/xsl/RNG2Schtrn.xsl;beginline=2;endline=7;md5=5b03236d293dc3784205542b409d2f53 \
17 "
18
19DEPENDS += "libxml2 libxslt"
20
21SRC_URI[sha256sum] = "a1613838aa6b89af4ba10a0f3a972836128801ed008078f8c1244e65958f1b24"
22
23SRC_URI += " \
24 file://0001-setupinfo.py-check-the-return-value.patch \
25"
26inherit pkgconfig pypi setuptools3
27
28# {standard input}: Assembler messages:
29# {standard input}:1488805: Error: branch out of range
30DEBUG_OPTIMIZATION:remove:mips = " -Og"
31DEBUG_OPTIMIZATION:append:mips = " -O"
32BUILD_OPTIMIZATION:remove:mips = " -Og"
33BUILD_OPTIMIZATION:append:mips = " -O"
34
35DEBUG_OPTIMIZATION:remove:mipsel = " -Og"
36DEBUG_OPTIMIZATION:append:mipsel = " -O"
37BUILD_OPTIMIZATION:remove:mipsel = " -Og"
38BUILD_OPTIMIZATION:append:mipsel = " -O"
39
40BBCLASSEXTEND = "native nativesdk"
41
42RDEPENDS:${PN} += "libxml2 libxslt ${PYTHON_PN}-compression"
43
44CLEANBROKEN = "1"