blob: 1608e03809d4d6310eddc032aa73d15406f4f78b [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Python package for creating and manipulating graphs and networks"
2HOMEPAGE = "http://networkx.github.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5cfa4d8f5881e0d053bb497130b9c73a"
5
6SRC_URI[sha256sum] = "c0946ed31d71f1b732b5aaa6da5a0388a345019af232ce2f49c766e2d6795c51"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-decorator \
12 ${PYTHON_PN}-netclient \
13 ${PYTHON_PN}-compression \
14 ${PYTHON_PN}-numbers \
15 ${PYTHON_PN}-pickle \
16 ${PYTHON_PN}-html \
17 ${PYTHON_PN}-xml \
18 ${PYTHON_PN}-json \
19 "