blob: e7f7f0b47bcb53f4c989985e7ac95047d5f5e58c [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
2HOMEPAGE = "https://github.com/idan/oauthlib"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482"
6
7SRC_URI[sha256sum] = "23a8208d75b902797ea29fd31fa80a15ed9dc2c6c16fe73f5d346f83f6fa27a2"
8
9inherit pypi setuptools3
10
11# The following configs & dependencies are from setuptools extras_require.
12# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
13# The upstream names may not correspond exactly to bitbake package names.
14#
15# Uncomment this line to enable all the optional features.
16#PACKAGECONFIG ?= "test signedtoken signals rsa"
17PACKAGECONFIG[test] = ",,,${PYTHON_PN}-blinker ${PYTHON_PN}-cryptography ${PYTHON_PN}-pytest ${PYTHON_PN}-pyjwt"
18PACKAGECONFIG[signedtoken] = ",,,${PYTHON_PN}-cryptography ${PYTHON_PN}-pyjwt"
19PACKAGECONFIG[signals] = ",,,${PYTHON_PN}-blinker"
20PACKAGECONFIG[rsa] = ",,,${PYTHON_PN}-cryptography"
21
22RDEPENDS:${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-crypt ${PYTHON_PN}-datetime ${PYTHON_PN}-json ${PYTHON_PN}-logging ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-unittest"