blob: de3c92c3d33712119c167c2120d8f5e455a3f70e [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ad081a0aede51e89f8da13333a8fb849"
7
8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=9.0.x;protocol=https \
9 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
11"
12SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
13
14inherit setuptools3
15
16DEPENDS += " \
17 zlib \
18 jpeg \
19 tiff \
20 freetype \
21 lcms \
22 openjpeg \
23"
24
25RDEPENDS:${PN} += " \
26 ${PYTHON_PN}-misc \
27 ${PYTHON_PN}-logging \
28 ${PYTHON_PN}-numbers \
29"
30
31CVE_PRODUCT = "pillow"
32
33S = "${WORKDIR}/git"
34
35RPROVIDES:${PN} += "python3-imaging"
36
37BBCLASSEXTEND = "native"