blob: 5e0ee7cb26ac328862e34dcd9a97a0bdc1b7b9f6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
7
8inherit pypi setuptools3
9
10SRC_URI[sha256sum] = "d975a6314fbf5c524d4981e24294739216b5fb81ef3c14b86fb4b045d6690907"
11
12# http://errors.yoctoproject.org/Errors/Details/184715/
13# Can't find required file: ../src/google/protobuf/descriptor.proto
14CLEANBROKEN = "1"
15
16UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
17
18DEPENDS += "protobuf"
19
20RDEPENDS:${PN} += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-netclient \
25 ${PYTHON_PN}-numbers \
26 ${PYTHON_PN}-pkgutil \
27 ${PYTHON_PN}-six \
28 ${PYTHON_PN}-unittest \
29"
30
31# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
32BBCLASSEXTEND = "native nativesdk"
33
34DISTUTILS_BUILD_ARGS += "--cpp_implementation"
35DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
36
37do_compile:prepend:class-native () {
38 export KOKORO_BUILD_NUMBER="1"
39}