blob: dfacb41f19c6eff7d9cd7dcd1f4b98ce17d82beb [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Seamless operability between C++11 and Python"
2HOMEPAGE = "https://github.com/wjakob/pybind11"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
5
6DEPENDS = "boost"
7
8SRC_URI = "git://github.com/pybind/pybind11.git;branch=master;protocol=https \
9 file://0001-Do-not-strip-binaries.patch \
10 file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
11"
12SRCREV = "f7b499615e14d70ab098a20deb0cdb3889998a1a"
13
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
19
20inherit cmake setuptools3 python3native
21
22do_configure() {
23 cmake_do_configure
24}
25
26do_compile() {
27 setuptools3_do_compile
28 cmake_do_compile
29}
30
31do_install() {
32 setuptools3_do_install
33 cmake_do_install
34}
35
36BBCLASSEXTEND = "native nativesdk"