blob: 10f624b484c6ab18d1ceb64bdaeb16d494fd1045 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
2DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library"
3HOMEPAGE = "https://github.com/pyca/pynacl"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
6
7SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba"
8
9PYPI_PACKAGE = "PyNaCl"
10
11inherit pypi setuptools3
12
13DEPENDS += "\
14 ${PYTHON_PN}-wheel-native \
15 ${PYTHON_PN}-cffi-native \
16 libsodium \
17"
18
19RDEPENDS:${PN} = "\
20 ${PYTHON_PN}-six \
21 ${PYTHON_PN}-cffi \
22 libsodium \
23"
24
25do_compile:prepend() {
26 export SODIUM_INSTALL=system
27}
28
29do_install:prepend() {
30 export SODIUM_INSTALL=system
31}