blob: 7e5599e4aae25c598641b5d875795b9ff0fc4168 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python project template generator with batteries included"
2DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
3After installation, it provides a new command [putup], which could be \
4used to create template Projects."
5
6HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
7SECTION = "devel/python"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
10
11inherit pypi setuptools3
12
13PYPI_PACKAGE = "PyScaffold"
14
15SRC_URI[sha256sum] = "46a2bbdf255ba2efc6c56ae1428249b61d56c4a3e54ef3db0d05fa97792011a5"
16
17BBCLASSEXTEND = "native nativesdk"
18
19RDEPENDS:${PN} += " \
20 python3-email \
21 python3-compression \
22"