blob: 5e4847b8d946bc9224348863aead85f372d227a4 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "unittest subTest() support and subtests fixture."
2DESCRIPTION = "Adds support for TestCase.subTest.\
3New subtests fixture, providing similar functionality for pure pytest tests."
4HOMEPAGE = "https://github.com/pytest-dev/pytest-subtests"
5BUGTRACKER = "https://github.com/pytest-dev/pytest-subtests/issues"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
9
10SRC_URI[sha256sum] = "3ebd306a8dcf75133f1742f288c82f36426ebcf8a132d4ee89782d20e84fc13a"
11
12inherit pypi setuptools3
13
14DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
15
16RDEPENDS:${PN} += " \
17 ${PYTHON_PN}-pytest \
18"
19
20BBCLASSEXTEND = "native nativesdk"