blob: 119342a4bd7f3b51283bcde7d505d50ea54cb302 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "acad2d8b20a1af07d4e4c9d2e9285c5ed9104354062f275f3fcd88dcef4f1326"
9
10RDEPENDS:${PN}:class-target += "\
11 ${PYTHON_PN}-datetime \
12 ${PYTHON_PN}-doctest \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pickle \
15 ${PYTHON_PN}-pprint \
16 ${PYTHON_PN}-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/pytz
31 install -d ${D}${PTEST_PATH}/pytz/tests
32 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
33 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
34
35}