blob: 8ad6acc875cf77c9ceea965255a13ce804a02a3c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A simple, safe single expression evaluator library"
2HOMEPAGE = "https://pypi.org/project/simpleeval/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7"
5
6SRC_URI[sha256sum] = "3e0be507486d4e21cf9d08847c7e57dd61a1603950399985f7c5a0be7fd33e36"
7
8inherit pypi setuptools3 ptest
9
10BBCLASSEXTEND = "native nativesdk"
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN} += " \
17 ${PYTHON_PN}-math \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_configure:prepend() {
25 sed -i -e "/use_2to3=True,/d" ${S}/setup.py
26}
27
28do_install_ptest() {
29 cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/
30}