blob: c2a51b9148516c3f8127faafa3cf7b1255e4843e [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
5
6SRC_URI[sha256sum] = "0e7c33d9a63e7ddfcb86780aac87befc2fbddf46c58dbb487e0855f7ceec283c"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-certifi \
12 ${PYTHON_PN}-cryptography \
13 ${PYTHON_PN}-email \
14 ${PYTHON_PN}-idna \
15 ${PYTHON_PN}-netclient \
16 ${PYTHON_PN}-pyopenssl \
17 ${PYTHON_PN}-threading \
18"
19
20CVE_PRODUCT = "urllib3"
21
22BBCLASSEXTEND = "native nativesdk"