blob: 2004670f62eb99f294581f16541189ab8191202a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001HOMEPAGE = "https://github.com/netdata/netdata/"
2SUMMARY = "Real-time performance monitoring"
3DESCRIPTION = "Netdata is high-fidelity infrastructure monitoring and troubleshooting. \
4 Open-source, free, preconfigured, opinionated, and always real-time."
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
7
8DEPENDS += "libuv util-linux zlib"
9
10SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BPN}-v${PV}.tar.gz"
11SRC_URI[sha256sum] = "20ba8695d87187787b27128ac3aab9b09aa29ca6b508c48542e0f7d50ec9322b"
12
13# default netdata.conf for netdata configuration
14SRC_URI += "file://netdata.conf"
15
16# file for providing systemd service support
17SRC_URI += "file://netdata.service"
18
19UPSTREAM_CHECK_URI = "https://github.com/netdata/netdata/releases"
20
21S = "${WORKDIR}/${BPN}-v${PV}"
22
23# Stop sending anonymous statistics to Google Analytics
24NETDATA_ANONYMOUS ??= "enabled"
25
26inherit pkgconfig autotools-brokensep useradd systemd
27
28LIBS:toolchain-clang:x86 = "-latomic"
29LIBS:riscv64 = "-latomic"
30LIBS:riscv32 = "-latomic"
31LIBS:mips = "-latomic"
32export LIBS
33
34#systemd
35SYSTEMD_PACKAGES = "${PN}"
36SYSTEMD_SERVICE:${PN} = "netdata.service"
37SYSTEMD_AUTO_ENABLE:${PN} = "enable"
38
39#User specific
40USERADD_PACKAGES = "${PN}"
41USERADD_PARAM:${PN} = "--system --no-create-home --home-dir ${localstatedir}/run/netdata --user-group netdata"
42
43PACKAGECONFIG ??= "https"
44PACKAGECONFIG[compression] = "--enable-compression, --disable-compression, lz4"
45PACKAGECONFIG[https] = "--enable-https, --disable-https, openssl"
46
47# ebpf doesn't compile (or detect) the cross compilation well
48EXTRA_OECONF += "--disable-ebpf"
49
50do_install:append() {
51 #set S UID for plugins
52 chmod 4755 ${D}${libexecdir}/netdata/plugins.d/apps.plugin
53
54 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
55 # Install systemd unit files
56 install -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system
58 sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service
59 fi
60
61 # Install default netdata.conf
62 install -d ${D}${sysconfdir}/netdata
63 install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/
64 sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf
65 sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf
66 sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf
67
68 if [ "${NETDATA_ANONYMOUS}" = "enabled" ]; then
69 touch ${D}${sysconfdir}/netdata/.opt-out-from-anonymous-statistics
70 fi
71
72 install --group netdata --owner netdata --directory ${D}${localstatedir}/cache/netdata
73 install --group netdata --owner netdata --directory ${D}${localstatedir}/lib/netdata
74
75 chown -R netdata:netdata ${D}${datadir}/netdata/web
76}
77
78FILES_${PN} += "${localstatedir}/cache/netdata/ ${localstatedir}/lib/netdata/"
79
80RDEPENDS:${PN} = "bash zlib"