blob: 9e1e357a8b374f7b6234301a2e276c489b205060 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "CircuitPython APIs for non-CircuitPython versions of Python such as CPython on Linux and MicroPython."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_Blinka"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=660e614bc7efb0697cc793d8a22a55c2"
5
6SRC_URI = "git://github.com/adafruit/Adafruit_Blinka.git;branch=main;protocol=https"
7SRCREV = "dc688f354fe779c9267c208b99f310af87e79272"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
15do_install:append() {
16# it ships ./bcm283x/pulseio/libgpiod_pulsein which is a prebuilt
17# 32bit binary therefore we should make this specific to 32bit rpi machines (based on bcm283x) only
18 if [ ${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '1', '0', d)} = "0" ]; then
19 rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/adafruit_blinka/microcontroller/bcm283x
20 fi
21}
22
23RDEPENDS:${PN} += " \
24 libgpiod \
25 python3-adafruit-platformdetect \
26 python3-adafruit-pureio \
27 python3-core \
28"
29
30RDEPENDS:${PN}:append:rpi = " rpi-gpio"
31
32COMPATIBLE_HOST:libc-musl:class-target = "null"
33