blob: 93491d43cc9973dc94a75445e8c138d98a80acf4 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "CircuitPython bus device classes to manage bus sharing."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_BusDevice"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ec69d6e9e6c85adfb7799d7f8cf044e"
5
6SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_BusDevice.git;branch=main;protocol=https"
7SRCREV = "1bfe8005293205e2f7b2cc498ab5a946f1133b40"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \
17 python3-core \
18"
19COMPATIBLE_HOST:libc-musl:class-target = "null"