blob: 3233c8f2bcb997824be27282a0f51c941c02795f [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "CircuitPython helper library provides higher level objects to control motors and servos."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_Motor"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b72678307cc7c10910b5ef460216af07"
5
6SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_Motor.git;branch=main;protocol=https"
7SRCREV = "2251bfc0501d0acfb96c0a43f4f2b4c6a10ca14e"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \
17 python3-core \
18"
19COMPATIBLE_HOST:libc-musl:class-target = "null"