blob: 39fe76aab750a18d3b686b6212045948387994cd [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "CircuitPython helper library for DC & Stepper Motor FeatherWing, Shield, and Pi Hat kits."
2HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_MotorKit"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ad4a8854b39ad474755ef1aea813bac"
5
6SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_MotorKit.git;branch=main;protocol=https"
7SRCREV = "8c1462b4129b21f6db156d1517abb017bb74b982"
8
9S = "${WORKDIR}/git"
10
11inherit setuptools3
12
13DEPENDS += "python3-setuptools-scm-native"
14
15RDEPENDS:${PN} += " \
16 python3-adafruit-blinka \
17 python3-adafruit-circuitpython-busdevice \
18 python3-adafruit-circuitpython-motor \
19 python3-adafruit-circuitpython-pca9685 \
20 python3-adafruit-circuitpython-register \
21 python3-core \
22"
23COMPATIBLE_HOST:libc-musl:class-target = "null"