blob: 6538f6a03b630aa267c08a3cb25265d8862a530e [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "Package that provides access to GPIO and other IO\
2functions on the Broadcom BCM 2835 chip, allowing access to the\
3GPIO pins on the 26 pin IDE plug on the RPi board"
4SECTION = "base"
5HOMEPAGE = "http://www.open.com.au/mikem/bcm2835"
6AUTHOR = "Mike McCauley (mikem@open.com.au)"
7
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-2.0-only"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
10
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011COMPATIBLE_MACHINE = "^rpi$"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012
13SRC_URI = "http://www.airspayce.com/mikem/bcm2835/bcm2835-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "b5dc426b4ff258bb1397442f98e40236"
16SRC_URI[sha256sum] = "b9fd10f7a80aadaed28a77168709b7c519568a63b6e98d0a50e9c5fe31bea6bb"
17
18inherit autotools
19
Patrick Williams213cb262021-08-07 19:21:33 -050020do_compile:append() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021 # Now compiling the examples provided by the package
22 mkdir -p ${B}/examples
23 for file in `ls ${S}/examples`; do
24 ${CC} ${LDFLAGS} ${S}/examples/${file}/${file}.c -o ${B}/examples/${file} -Bstatic -L${B}/src -lbcm2835 -I${S}/src
25 done
26}
27
Patrick Williams213cb262021-08-07 19:21:33 -050028do_install:append() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029 install -d ${D}/${libdir}/${BPN}
30 for file in ${B}/examples/*
31 do
32 install -m 0755 ${file} ${D}/${libdir}/${BPN}
33 done
34}
35
36PACKAGES += "${PN}-tests"
37
Patrick Williams213cb262021-08-07 19:21:33 -050038RDEPENDS:${PN}-dev = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:${PN} = ""
41FILES:${PN}-tests = "${libdir}/${BPN}"
42FILES:${PN}-dbg += "${libdir}/${BPN}/.debug"