blob: f14941b823f04b2de054a0bb3042c9cf0d32913c [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Python interface to the Raspberry Pi camera module"
2DESCRIPTION = "This package provides a pure Python interface to the Raspberry Pi camera module for Python 2.7 (or above) or Python 3.2 (or above)."
3HOMEPAGE = "https://github.com/waveform80/picamera"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4de8aab427192e4a8322a71375d20e21"
7
8RDEPENDS:${PN} = "python3-numbers \
9 python3-ctypes \
10 python3-colorzero \
11 picamera-libs \
12"
13
14SRC_URI = "git://git@github.com/waveform80/picamera.git;protocol=ssh;branch=master"
15SRCREV = "7e4f1d379d698c44501fb84b886fadf3fc164b70"
16
17S = "${WORKDIR}/git"
18
19inherit setuptools3
20
21COMPATIBLE_HOST = "null"
22COMPATIBLE_HOST:rpi:libc-glibc = "(arm.*)-linux"