blob: 80c9014153885fdedb0e84d77d9fd252fc834443 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "LibHTP is a security-aware parser for the HTTP protocol and the related bits and pieces."
2
3require suricata.inc
4
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=2;md5=596ab7963a1a0e5198e5a1c4aa621843"
6
7SRC_URI = "git://github.com/OISF/libhtp.git;protocol=https;branch=0.5.x"
8SRCREV = "6b70803c45894da7a591b2305498335e6df4f9a3"
9
10DEPENDS = "zlib"
11
12inherit autotools-brokensep pkgconfig
13
14CFLAGS += "-D_DEFAULT_SOURCE"
15
16#S = "${WORKDIR}/suricata-${VER}/${BPN}"
17
18S = "${WORKDIR}/git"
19
20do_configure () {
21 cd ${S}
22 ./autogen.sh
23 oe_runconf
24}
25
26RDEPENDS:${PN} += "zlib"
27