blob: 8a0b1ee8d9b0034930be8065db93fa4e58e39b24 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Google Authenticator PAM module"
2HOME_PAGE = "https://github.com/google/google-authenticator-libpam"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
4LICENSE = "Apache-2.0"
5
6SRC_URI = "git://github.com/google/google-authenticator-libpam.git;branch=master;protocol=https"
7SRCREV = "962f353aac6cfc7b804547319db40f8b804f0b6c"
8
9DEPENDS = "libpam"
10
11S = "${WORKDIR}/git"
12
13inherit autotools features_check
14
15REQUIRED_DISTRO_FEATURES = "pam"
16
17# Use the same dir location as PAM
18EXTRA_OECONF = "--libdir=${base_libdir}"
19
20PACKAGES += "pam-google-authenticator"
21FILES:pam-google-authenticator = "${base_libdir}/security/pam_google_authenticator.so"
22
23RDEPNEDS_pam-google-authenticator = "libpam"