blob: b92740de32a135f3cc0492b06f3a7ab4a6a781b5 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Line-oriented text editor -- selftest variant"
2HOMEPAGE = "http://www.gnu.org/software/ed/"
3
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LICENSE = "GPL-3.0-or-later"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \
6 file://ed.h;endline=20;md5=4e36b7a40e137f42aee718165590d125 \
7 file://main.c;endline=17;md5=c5b8f78f115df187af76868a2aead16a"
8
9SECTION = "base"
10
11# LSB states that ed should be in /bin/
12bindir = "${base_bindir}"
13
14SRC_URI = "${GNU_MIRROR}/ed/ed-${PV}.tar.lz"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015RECIPE_NO_UPDATE_REASON = "This recipe is used in selftest and shouldn't be updated otherwise"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016
17SRC_URI[md5sum] = "7f4a54fa7f366479f03654b8af645fd0"
18SRC_URI[sha256sum] = "ffb97eb8f2a2b5a71a9b97e3872adce953aa1b8958e04c5b7bf11d556f32552a"
19
20S = "${WORKDIR}/ed-${PV}"
21
22EXTRA_OEMAKE = "-e MAKEFLAGS="
23
24inherit texinfo
25
26do_configure() {
27 ${S}/configure
28}
29
30do_install() {
31 oe_runmake 'DESTDIR=${D}' install
32 # Info dir listing isn't interesting at this point so remove it if it exists.
33 if [ -e "${D}${infodir}/dir" ]; then
34 rm -f ${D}${infodir}/dir
35 fi
36}
Andrew Geissler5a43b432020-06-13 10:46:56 -050037
38BBCLASSEXTEND = "native"