blob: b1441e65dd5943f9f95f4cc7206730a10b324681 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001inherit pip_install_wheel setuptools3-base
2
3DEPENDS += "python3 python3-setuptools-native python3-wheel-native"
4
5setuptools_build_meta_do_configure () {
6 mkdir -p ${S}/dist
7 cat > ${S}/build-it.py << EOF
8from setuptools import build_meta
9wheel = build_meta.build_wheel('./dist')
10print(wheel)
11EOF
12}
13
14setuptools_build_meta_do_compile () {
15 nativepython3 ${S}/build-it.py
16}
17
18EXPORT_FUNCTIONS do_configure do_compile