Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Tools to manipulate UEFI variables" |
| 2 | DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility" |
| 3 | HOMEPAGE = "https://github.com/rhboot/efivar" |
| 4 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 5 | LICENSE = "LGPL-2.1-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" |
| 7 | |
| 8 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 9 | |
| 10 | SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \ |
| 11 | file://0001-docs-do-not-build-efisecdb-manpage.patch \ |
| 12 | file://0001-src-Makefile-build-util.c-separately-for-makeguids.patch \ |
| 13 | " |
| 14 | SRCREV = "1753149d4176ebfb2b135ac0aaf79340bf0e7a93" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit pkgconfig |
| 19 | |
| 20 | export CCLD_FOR_BUILD = "${BUILD_CCLD}" |
| 21 | |
| 22 | # Upstream uses --add-needed in gcc.specs which gold doesn't support, so |
| 23 | # enforce BFD. |
| 24 | LDFLAGS += "-fuse-ld=bfd" |
| 25 | |
| 26 | do_compile() { |
| 27 | oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}" |
| 28 | } |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake install DESTDIR=${D} |
| 32 | } |
| 33 | |
| 34 | BBCLASSEXTEND = "native" |
| 35 | |
| 36 | RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs" |
| 37 | |
| 38 | CLEANBROKEN = "1" |
| 39 | # https://github.com/rhboot/efivar/issues/202 |
| 40 | COMPATIBLE_HOST:libc-musl = 'null' |