blob: 68c4b4b914a890906b81ef6d690ebea23ee6b540 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00006LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \
11 file://0001-docs-do-not-build-efisecdb-manpage.patch \
12 file://0001-src-Makefile-build-util.c-separately-for-makeguids.patch \
13 "
14SRCREV = "1753149d4176ebfb2b135ac0aaf79340bf0e7a93"
15
16S = "${WORKDIR}/git"
17
18inherit pkgconfig
19
20export CCLD_FOR_BUILD = "${BUILD_CCLD}"
21
22# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
23# enforce BFD.
24LDFLAGS += "-fuse-ld=bfd"
25
26do_compile() {
27 oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}"
28}
29
30do_install() {
31 oe_runmake install DESTDIR=${D}
32}
33
34BBCLASSEXTEND = "native"
35
36RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs"
37
38CLEANBROKEN = "1"
39# https://github.com/rhboot/efivar/issues/202
40COMPATIBLE_HOST:libc-musl = 'null'