blob: 1b536de1e355317cbd6928ed10cc96d1033344aa [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
3DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others."
4BUGTRACKER = "https://github.com/libuv/libuv/issues"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=a68902a430e32200263d182d44924d47"
7
8SRCREV = "988f2bfc4defb9a85a536a3e645834c161143ee0"
9SRC_URI = "git://github.com/libuv/libuv;branch=v1.x;protocol=https"
10
11S = "${WORKDIR}/git"
12
13inherit autotools
14
15do_configure() {
16 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
17 oe_runconf
18}
19
20BBCLASSEXTEND = "native"