blob: 6c5d3150346e12f422fa9745facf71f81a06f7c9 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Embedded Linux Library"
2HOMEPAGE = "https://01.org/ell"
3DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
4low-level functionality for system daemons. It typically has no \
5dependencies other than the Linux kernel, C standard library, and \
6libdl (for dynamic linking). While ELL is designed to be efficient \
7and compact enough for use on embedded Linux platforms, it is not \
8limited to resource-constrained systems."
9SECTION = "libs"
10LICENSE = "LGPL-2.1-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
12
13DEPENDS = "dbus"
14
15inherit autotools pkgconfig
16
17SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
18 "
19SRC_URI[sha256sum] = "9894943042a5d6165d3e5cc354f92274fb1304004d02b4bee682ab6067cdbbd5"
20
21do_configure:prepend () {
22 mkdir -p ${S}/build-aux
23}