blob: a1883de0ebe53a86bf8993a9e66f70d10a229660 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Simple initramfs image artifact generation for tiny images.
2DESCRIPTION = "Tiny image capable of booting a device. The kernel includes \
3the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004first 'init' program more efficiently. core-image-tiny-initramfs doesn't \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005actually generate an image but rather generates boot and rootfs artifacts \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006that can subsequently be picked up by external image generation tools such as wic."
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008VIRTUAL-RUNTIME_dev_manager ?= "busybox-mdev"
9
Brad Bishop316dfdd2018-06-25 12:45:53 -040010PACKAGE_INSTALL = "initramfs-live-boot-tiny packagegroup-core-boot dropbear ${VIRTUAL-RUNTIME_base-utils} ${VIRTUAL-RUNTIME_dev_manager} base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
12# Do not pollute the initrd image with rootfs features
13IMAGE_FEATURES = ""
14
15export IMAGE_BASENAME = "core-image-tiny-initramfs"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050016IMAGE_NAME_SUFFIX ?= ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017IMAGE_LINGUAS = ""
18
19LICENSE = "MIT"
20
21# don't actually generate an image, just the artifacts needed for one
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023
24inherit core-image
25
26IMAGE_ROOTFS_SIZE = "8192"
27IMAGE_ROOTFS_EXTRA_SPACE = "0"
28
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029# Use the same restriction as initramfs-live-install
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000030COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm).*-linux"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031
32python tinyinitrd () {
33 # Modify our init file so the user knows we drop to shell prompt on purpose
34 newinit = None
35 with open(d.expand('${IMAGE_ROOTFS}/init'), 'r') as init:
36 newinit = init.read()
37 newinit = newinit.replace('Cannot find $ROOT_IMAGE file in /run/media/* , dropping to a shell ', 'Poky Tiny Reference Distribution:')
38 with open(d.expand('${IMAGE_ROOTFS}/init'), 'w') as init:
39 init.write(newinit)
40}
41
42IMAGE_PREPROCESS_COMMAND += "tinyinitrd;"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050043
44QB_KERNEL_CMDLINE_APPEND += "debugshell=3 init=/bin/busybox sh init"