blob: d5c05ff8e579815333ac91acd47990bf2212a39c [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "helper tools for all init systems"
2DESCRIPTION = "This package contains helper tools that are necessary for switching between \
3the various init systems that Debian contains (e. g. sysvinit or \
4systemd). An example is deb-systemd-helper, a script that enables systemd unit \
5files without depending on a running systemd. \
6\
7It also includes the \"service\", \"invoke-rc.d\", and \"update-rc.d\" scripts which \
8provide an abstraction for enabling, disabling, starting, and stopping \
9services for all supported Debian init systems as specified by the policy. \
10\
11While this package is maintained by pkg-systemd-maintainers, it is NOT \
12specific to systemd at all. Maintainers of other init systems are welcome to \
13include their helpers in this package."
14HOMEPAGE = "https://salsa.debian.org/debian/init-system-helpers"
15SECTION = "base"
16LICENSE = "BSD-3-Clause & GPL-2.0-only"
17LIC_FILES_CHKSUM = "file://debian/copyright;md5=ee2b1830fcfead84d07bc060ec43e072"
18
19SRCREV = "bbe4b508f3216cdc124683ba449e2295974a6b4a"
20SRC_URI = "git://salsa.debian.org/debian/init-system-helpers.git;protocol=https;branch=master"
21
22S = "${WORKDIR}/git"
23
24do_configure[noexec] = "1"
25do_compile[noexec] = "1"
26
27do_install() {
28 install -d -m 0755 ${D}${sbindir}
29 install -m 0755 ${S}/script/invoke-rc.d ${D}${sbindir}
30 install -m 0755 ${S}/script/service ${D}${sbindir}
31}
32
33PACKAGES += "${PN}-invoke-rc.d ${PN}-service"
34
35FILES:${PN} = ""
36FILES:${PN}-invoke-rc.d = "${sbindir}/invoke-rc.d"
37FILES:${PN}-service = "${sbindir}/service"
38
39ALLOW_EMPTY:${PN} = "1"
40
41RRECOMMENDS:${PN} += "${PN}-invoke-rc.d ${PN}-service"