blob: abc858308795b2a9451c5091fde3b67c7c908a23 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "A minimal seat management daemon, and a universal seat management library."
2DESCRIPTION = "Seat management takes care of mediating access to shared devices (graphics, input), without requiring the applications needing access to be root."
3HOMEPAGE = "https://git.sr.ht/~kennylevinsen/seatd"
4
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=715a99d2dd552e6188e74d4ed2914d5a"
8
9SRC_URI = "git://git.sr.ht/~kennylevinsen/seatd;protocol=https;branch=master \
10 file://init"
11SRCREV = "88db55f6068c1c01d85b61aa6adff0a6b2a8dce8"
12S = "${WORKDIR}/git"
13
14inherit meson pkgconfig update-rc.d
15
16PACKAGECONFIG ?= " \
17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
18 libseat-builtin \
19"
20
21PACKAGECONFIG[libseat-builtin] = "-Dlibseat-builtin=enabled,-Dlibseat-builtin=disabled"
22PACKAGECONFIG[systemd] = ",,systemd"
23
24do_install:append() {
25 if [ "${VIRTUAL-RUNTIME_init_manager}" != "systemd" ]; then
26 install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/seatd
27 fi
28}
29
30INITSCRIPT_NAME = "seatd"
31INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
32INHIBIT_UPDATERCD_BBCLASS = "${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', '1', '', d)}"