blob: ba5ce7b9bb2e0d534c606756721004e04589917c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001require automake.inc
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS:class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS:${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS:${PN}:class-native = "autoconf-native hostperl-runtime-native"
20
21SRC_URI += "\
22 file://0001-automake-Update-for-python.m4-to-respect-libdir.patch \
23 file://buildtest.patch \
24 file://performance.patch \
25 file://new_rt_path_for_test-driver.patch \
26 file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \
27 file://0001-build-fix-race-in-parallel-builds.patch \
28 "
29
30SRC_URI[sha256sum] = "07bd24ad08a64bc17250ce09ec56e921d6343903943e99ccf63bbf0705e34605"
31
32PERL = "${USRBINPATH}/perl"
33PERL:class-native = "${USRBINPATH}/env perl"
34PERL:class-nativesdk = "${USRBINPATH}/env perl"
35
36CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
37
38do_install:append () {
39 install -d ${D}${datadir}
40}
41
42BBCLASSEXTEND = "native nativesdk"