blob: e5b2057f26287fbb8500796e815645bc56a81d14 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "GPL-2.0-only & LGPL-2.1-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +000011LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \
13 file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \
14"
15SECTION = "base"
16DEPENDS = "lzo util-linux zlib"
17
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git;branch=master \
19 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
20 file://0001-btrfs-progs-kerncompat-add-local-definition-for-alig.patch \
21 "
22SRCREV = "8ad326b2f28c044cb6ed9016d7c3285e23b673c8"
23S = "${WORKDIR}/git"
24
25PACKAGECONFIG ??= " \
26 programs \
27 convert \
28 python \
29 crypto-builtin \
30"
31PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
32PACKAGECONFIG[programs] = "--enable-programs,--disable-programs"
33PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs"
34PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned"
35PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
36PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
37PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev"
38
39# Pick only one crypto provider
40PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin"
41PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt"
42PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium"
43PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi"
44
45inherit autotools-brokensep pkgconfig manpages
46inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'setuptools3-base', '', d)}
47
48CLEANBROKEN = "1"
49
50EXTRA_OECONF = "--enable-largefile"
51EXTRA_OECONF:append:libc-musl = " --disable-backtrace "
52EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
53EXTRA_PYTHON_CFLAGS:class-native = ""
54EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
55EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
56
57do_configure:prepend() {
58 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
59 mkdir -p ${S}/config
60 cp -f $(automake --print-libdir)/install-sh ${S}/config/
61}
62
63
64do_install:append() {
65 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
66 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
67 fi
68}
69
70RDEPENDS:${PN} = "libgcc"
71
72BBCLASSEXTEND = "native nativesdk"