blob: 11d939c7aa83fe0386ec8edcca7cdaca71812c6c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "GPL-3.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +000010LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=8fe0fdfdc7a892516526b86c28d06a16"
11
12DEPENDS = "zstd"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
15SRC_URI[sha256sum] = "f0d3cff5d555d6868f14a7d05696f0370074e475304fd5aa152b98f892364981"
16
17UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
18
19inherit cmake
20
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native nativesdk"
24
25PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
26PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"