blob: f16e716b0dc252454c1ad30883929b8ee422f8a7 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
2DESCRIPTION = "Software package manager that installs, updates, and removes \
3packages on RPM-based Linux distributions. It automatically computes \
4dependencies and determines the actions required to install packages."
5HOMEPAGE = "https://github.com/rpm-software-management/dnf"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-only"
Andrew Geisslereff27472021-10-29 15:35:00 -05007LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \
9 "
10
Andrew Geissler595f6302022-01-24 19:11:47 +000011SRC_URI = "git://github.com/rpm-software-management/dnf.git;branch=master;protocol=https \
Andrew Geisslereff27472021-10-29 15:35:00 -050012 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
13 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
14 file://0005-Do-not-prepend-installroot-to-logdir.patch \
15 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
16 file://0030-Run-python-scripts-using-env.patch \
17 file://0001-set-python-path-for-completion_helper.patch \
18 file://0001-dnf-write-the-log-lock-to-root.patch \
19 "
20
21SRCREV = "bd691b784f2158e633072d368579898d740e4347"
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
23
24S = "${WORKDIR}/git"
25
Andrew Geissler595f6302022-01-24 19:11:47 +000026inherit cmake gettext bash-completion setuptools3-base systemd
Andrew Geisslereff27472021-10-29 15:35:00 -050027
28DEPENDS += "libdnf librepo libcomps python3-iniparse"
29
30# manpages generation requires http://www.sphinx-doc.org/
31EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
32
33BBCLASSEXTEND = "native nativesdk"
34
35RDEPENDS:${PN} += " \
36 python3-core \
37 python3-codecs \
38 python3-netclient \
39 python3-email \
40 python3-threading \
Andrew Geisslereff27472021-10-29 15:35:00 -050041 python3-logging \
42 python3-fcntl \
43 librepo \
44 python3-shell \
45 libcomps \
46 libdnf \
47 python3-sqlite3 \
48 python3-compression \
49 python3-rpm \
50 python3-iniparse \
51 python3-json \
52 python3-curses \
53 python3-misc \
54 python3-gpg \
55 "
56
57RDEPENDS:${PN}:class-native = ""
58
59RRECOMMENDS:${PN}:class-target += "gnupg"
60
61# Create a symlink called 'dnf' as 'make install' does not do it, but
62# .spec file in dnf source tree does (and then Fedora and dnf documentation
63# says that dnf binary is plain 'dnf').
64do_install:append() {
Andrew Geissler595f6302022-01-24 19:11:47 +000065 ln -rs ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
66 ln -rs ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
Andrew Geisslereff27472021-10-29 15:35:00 -050067}
68
69# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
70do_install:append:class-native() {
71 create_wrapper ${D}/${bindir}/dnf \
72 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
73 RPM_NO_CHROOT_FOR_SCRIPTS=1
74}
75
76do_install:append:class-nativesdk() {
77 create_wrapper ${D}/${bindir}/dnf \
78 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
79 RPM_NO_CHROOT_FOR_SCRIPTS=1
80}
81
82SYSTEMD_SERVICE:${PN} = "dnf-makecache.service dnf-makecache.timer \
83 dnf-automatic.service dnf-automatic.timer \
84 dnf-automatic-download.service dnf-automatic-download.timer \
85 dnf-automatic-install.service dnf-automatic-install.timer \
86 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
87"
88SYSTEMD_AUTO_ENABLE ?= "disable"
89
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000090SKIP_RECIPE[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"