blob: 32c1b2fc063fcb7feb3a75ef63f3bf93b802fe32 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Program for creating simple man pages"
2HOMEPAGE = "https://www.gnu.org/software/help2man/"
3DESCRIPTION = "help2man is a tool for automatically generating simple manual pages from program output."
4SECTION = "devel"
5LICENSE = "GPL-3.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7
8SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
9SRC_URI[sha256sum] = "fd99a664ec4be9a86a0dd89719989f14f367a9c079d75d0e1d71e18a7bb51b03"
10
11inherit autotools
12
13# This is a hand-maintained aclocal.m4 but our autotools class currently deletes
14# aclocal.m4.
15EXTRA_AUTORECONF += "--exclude=aclocal"
16
17EXTRA_OECONF = "--disable-nls"
18
19do_install:append () {
20 # Make sure we use /usr/bin/env perl
21 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
22}
23
24BBCLASSEXTEND = "native nativesdk"