blob: 791404e5bc401ea7d1cc779f98bbe9d39a527ef5 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Perl module for reading and writing XML"
2DESCRIPTION = "The XML::Simple Perl module provides a simple API layer \
3on top of an underlying XML parsing module to maintain XML files \
4(especially configuration files). It is a blunt rewrite of XML::Simple \
5(by Grant McLean) to use the XML::LibXML parser for XML structures, \
6where the original uses plain Perl or SAX parsers."
7HOMEPAGE = "http://search.cpan.org/~markov/XML-LibXML-Simple-0.93/lib/XML/LibXML/Simple.pod"
8SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010LIC_FILES_CHKSUM = "file://LICENSE;md5=cf206df8c9fe775f1d4c484386491eac"
11DEPENDS += "libxml-parser-perl"
12
13SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "bb841dce889a26c89a1c2739970e9fbc"
16SRC_URI[sha256sum] = "531fddaebea2416743eb5c4fdfab028f502123d9a220405a4100e68fc480dbf8"
17
18S = "${WORKDIR}/XML-Simple-${PV}"
19
20EXTRA_PERLFLAGS = "-I ${PERLHOSTLIB}"
21
22inherit cpan ptest-perl
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} += " \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025 libxml-namespacesupport-perl \
26 libxml-parser-perl \
27 libxml-sax-perl \
28"
29
Patrick Williams213cb262021-08-07 19:21:33 -050030RDEPENDS:${PN}-ptest += " \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031 perl-module-file-temp \
32 perl-module-test-more \
33"
34
35BBCLASSEXTEND = "native"