blob: d73e5810b800250b32710a3da695629b1102e50b [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema"
2HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "dtschema"
9
10SRC_URI[sha256sum] = "1b92b3b9a31b6e4b8b2be70dbf3065775530bc4c52e991955b67be19741114c5"
11
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
14
15BBCLASSEXTEND = "native nativesdk"