blob: a00ea1810e326ed38a3a5e1005c4a98b39525c9c [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "This provides a PEP 517 build backend for packages using Flit."
2DESCRIPTION = "This provides a PEP 517 build backend for packages using \
3Flit. The only public interface is the API specified by PEP 517, at \
4flit_core.buildapi."
5HOMEPAGE = "https://github.com/pypa/flit"
6BUGTRACKER = "https://github.com/pypa/flit/issues"
7
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=41eb78fa8a872983a882c694a8305f08"
10
11SRC_URI[sha256sum] = "b1464e006df4df4c8eeb37671c0e0ce66e1d04e4a36d91b702f180a25fde3c11"
12
13inherit pip_install_wheel python3native python3-dir pypi setuptools3-base
14
15DEPENDS:remove:class-native = " python3-pip-native"
16DEPENDS:append:class-native = " unzip-native"
17
18# We need the full flit tarball
19PYPI_PACKAGE = "flit"
20
21PIP_INSTALL_PACKAGE = "flit_core"
22PIP_INSTALL_DIST_PATH = "${S}/flit_core/dist"
23
24do_compile () {
25 nativepython3 flit_core/build_dists.py
26}
27
28do_install:class-native () {
29 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
30 unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ./flit_core/dist/flit_core-${PV}-py3-none-any.whl
31}
32
33FILES:${PN} += "\
34 ${PYTHON_SITEPACKAGES_DIR}/flit_core/* \
35 ${PYTHON_SITEPACKAGES_DIR}/flit_core-${PV}.dist-info/* \
36"
37
38PACKAGES =+ "${PN}-tests"
39
40FILES:${PN}-tests += "\
41 ${PYTHON_SITEPACKAGES_DIR}/flit_core/tests/* \
42"
43
44BBCLASSEXTEND = "native nativesdk"
45