blob: 99837848a67ecddbefc68a09ebd3f910faee1c4d [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Python interface to libarchive"
2DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \
3 dynamically load and access the C library."
4HOMEPAGE = "https://github.com/Changaco/python-libarchive-c"
5LICENSE = "CC0-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc"
7
8PYPI_PACKAGE = "libarchive-c"
9
10inherit pypi setuptools3
11
12PIP_INSTALL_PACKAGE = "libarchive_c"
13
14SRC_URI[sha256sum] = "a5b41ade94ba58b198d778e68000f6b7de41da768de7140c984f71d7fa8416e5"
15
16RDEPENDS:${PN} += "\
17 libarchive \
18 ${PYTHON_PN}-ctypes \
19 ${PYTHON_PN}-mmap \
20 ${PYTHON_PN}-logging \
21"
22
23BBCLASSEXTEND = "native"