blob: bd46b294ae956942b91d1854d8e90714061bd094 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
9
10PYPI_PACKAGE = "python-magic"
11PIP_INSTALL_PACKAGE = "python_magic"
12
13inherit pypi setuptools3
14
15SRC_URI[sha256sum] = "21f5f542aa0330f5c8a64442528542f6215c8e18d2466b399b0d9d39356d83fc"
16
17RDEPENDS:${PN} += "file \
18 ${PYTHON_PN}-ctypes \
19 ${PYTHON_PN}-io \
20 ${PYTHON_PN}-logging \
21 ${PYTHON_PN}-shell"
22
23BBCLASSEXTEND = "native"