blob: 0ceddcb68a2d950380d2a72bcba8fa875b43764b [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "pyelftools is a pure-Python library for parsing and analyzing ELF files and DWARF debugging information"
2HOMEPAGE = "https://github.com/eliben/pyelftools"
3SECTION = "devel/python"
4LICENSE = "PD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5ce2a2b07fca326bc7c146d10105ccfc"
6
7SRC_URI[sha256sum] = "53e5609cac016471d40bd88dc410cd90755942c25e58a61021cfdf7abdfeacff"
8
9PYPI_PACKAGE = "pyelftools"
10
11inherit pypi setuptools3
12
13BBCLASSEXTEND = "native"
14
15RDEPENDS:${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"