blob: cfb075f65f3e1aa641b9a61dc46079e2e5c98429 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Software Construction tool (make/autotools replacement)"
2HOMEPAGE = "https://github.com/SCons/scons"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d903b0b8027f461402bac9b5169b36f7"
6
7SRC_URI += " file://0001-Fix-man-page-installation.patch"
8SRC_URI[sha256sum] = "d47081587e3675cc168f1f54f0d74a69b328a2fc90ec4feb85f728677419b879"
9
10PYPI_PACKAGE = "SCons"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011PIP_INSTALL_DIST_PATH = "${B}/build/dist"
Andrew Geissler595f6302022-01-24 19:11:47 +000012
13inherit pypi setuptools3
14
15RDEPENDS:${PN}:class-target = "\
16 python3-core \
17 python3-compression \
18 python3-fcntl \
19 python3-importlib-metadata \
20 python3-io \
21 python3-json \
22 python3-shell \
23 python3-pickle \
24 python3-pkg-resources \
25 python3-pprint \
26 "
27
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000028do_install:append() {
29 install -d ${D}${mandir}/man1
30 mv ${D}${prefix}/scons*.1 ${D}${mandir}/man1/
31}
32FILES:${PN}-doc += "${mandir}/man1/scons*.1"
33
34do_install:append:class-native() {
35 create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
36}
37
38BBCLASSEXTEND = "native"